Skip to content

Extensions

In the console: Settings › MTA › Session › Extensions

Which optional SMTP features this server offers to other servers. For specialists.

SMTP Extensions

Pipelining

Enables SMTP pipelining (RFC 2920), which enables multiple commands to be sent in a single request to speed up communication between the client and server.

Settings of their own: see Expression. Name in the API: pipelining.

Chunking

Enables chunking (RFC 1830), an extension that allows large messages to be transferred in chunks which may reduce the load on the network and server.

Settings of their own: see Expression. Name in the API: chunking.

Require TLS

Enables require TLS (RFC 8689), an extension that allows clients to require TLS encryption for the SMTP session.

Settings of their own: see Expression. Name in the API: requireTls.

No-Soliciting

Specifies the text to include in the NOSOLICITING (RFC 3865) message, which indicates that the server does not accept unsolicited commercial email (UCE or spam)

Settings of their own: see Expression. Name in the API: noSoliciting.

DSN

Enables delivery status notifications (RFC 3461), which allows the sender to request a delivery status notification (DSN) from the recipient's mail server.

Settings of their own: see Expression. Name in the API: dsn.

EXPN

Specifies whether to enable the EXPN command, which allows the sender to request the membership of a mailing list. It is recommended to disable this command to prevent spammers from harvesting email addresses.

Settings of their own: see Expression. Name in the API: expn.

VRFY

Specifies whether to enable the VRFY command, which allows the sender to verify the existence of a mailbox. It is recommended to disable this command to prevent spammers from harvesting email addresses.

Settings of their own: see Expression. Name in the API: vrfy.

Future Release

Specifies the maximum time that a message can be held for delivery using the FUTURERELEASE (RFC 4865) extension.

Settings of their own: see Expression. Name in the API: futureRelease.

Deliver By

Specifies the maximum delivery time for a message using the DELIVERBY (RFC 2852) extension, which allows the sender to request a specific delivery time for a message.

Settings of their own: see Expression. Name in the API: deliverBy.

MT Priority

Specifies the priority assignment policy to advertise on the MT-PRIORITY (RFC 6710) extension, which allows the sender to specify a priority for a message. Available policies are mixer, stanag4406 and nsep, or false to disable this extension.

Settings of their own: see Expression. Name in the API: mtPriority.